2009-11-13 OpenBSD (macppc)

I made the last backup of my iBook Alpinobombus and installed OpenBSD/macppc on it. Burn the *install46.iso* image onto a CD, insert into iBook, hold c while booting.

macppc

The wireless network needs some sort of firmware which I downloaded from the net and saved on an USB stick. See `man bwi` for the location. Anyway, now I needed to get the package from the stick onto the laptop.

I don’t understand why *i* is relevant, but this ¹ worked:

¹

mount -t msdos /dev/sd0i /mnt/stick

I kept trying sd0a… 😢

I added the following line to `/etc/fstab`:

/dev/sd0i /mnt/stick msdos rw,noauto 0 0

I hope `mount /mnt/stick` will work from now on.

Back to the network! With `pkg_add bwi-firmware-1.4.tgz` finally available I installed the firmware for the Airport wireless card in my old iBook. 👌

Use `ifconfig` to verify that *bwi0* is your wireless interface. Use `ifconfig bwi0 scan` to list the networks available and find yours.

Now the WPA stuff for my Schroeder network…

ifconfig bwi0 nwid Schroeder wpa wpapsk `wpa-psk Schroeder "*secret*"`
ifconfig bwi0 up
dhclient bwi0

And it seems to work. I can `ping www.google.com` – win! 😄

Thus, I removed any `/etc/hostname.*` files that didn’t work and created a single `/etc/hostname.bwi0` file containing the following line:

dhcp nwid Schroeder wpa wpapsk `wpa-psk Schroeder "*secret*"`

I’m surprised it works!

Tomorrow:

1. fixing the keymap layout – `kbd -l` lists de and others, but no Swiss German layout → *update* 💡 Apparently *sg* stands for Swiss German! 😄

2. setting up ports, getting Emacs ← very important! ;)

3. setting up email

4. Much later... Firefox?

Swiss German layout

Luckily I’ve used US keyboards before, and I’ve used vi before. 👌

Second Day

`echo sg > /etc/kbdtype` – apparently I can use wsconsctl to remap more keys.

wsconsctl

Apparently there are no virtual terminals because there’s no VGA card, but there’s an alternative to GNU screen: tmux.

tmux

I realized that there are two levels of packages: 1. binary packages 2. the ports system. I started by setting

PKG_PATH=ftp://mirror.switch.ch/pub/OpenBSD/4.6/packages/`machine -a`/:ftp://ftp.wu-wien.ac.at/pub/OpenBSD/4.6/packages/`machine -a`/:ftp://ftp.OpenBSD.org/pub/OpenBSD/4.6/packages/`machine -a`/

in my `.profile`. ²

²

In order to test this, I decided to run `sudo pkg_add -v mutt`.

At the same time I feel like setting up the ports system by downloading `ports.tar.gz`. ³

³

Need Firefox and Emacs!

​#OpenBSD ​#macppc ​#iBook ​#Gadgets ​#Software

Comments

(Please contact me if you want to remove your comment.)

What about using the wired network to get the wireless firmware onto the macbook?

– Harald Wagener 2009-11-13 17:20 UTC

Harald Wagener

---

Recht hast du. Habe ich aber auf die Schnelle auch nicht hingebracht. Mit etwas Suchen auf dem Internet und blödem Abtippen der Beispiele bin ich dann auf eine Lösung gekommen. 😄

– Alex Schroeder 2009-11-14 01:12 UTC

Alex Schroeder